Starting application on PPC gives an error

Discussions about the smartphone versions
Post Reply
vasco_nl
Posts: 37
Joined: Tue Jul 24, 2007 22:25

Starting application on PPC gives an error

Post by vasco_nl » Tue Jul 24, 2007 22:35

I've buy the PC and PPC version and synchronize my log to my PPC.

When I run the PPC version I get an error first.
The error is: "1: FormatException"
This error comes with load logbook.

After I press ok the program run normal except for the tab "Comments", there is a lot of garbage between the normal text.

I have installed also de NET en SQL software that is on your download page by the PPC version.
My PPC is Microsoft Pocket PC version 4.20.1081 (build 13100) or Windows Mobile 2003 if you like.

What is the solution for this problem?

vasco_nl
Posts: 37
Joined: Tue Jul 24, 2007 22:25

Post by vasco_nl » Tue Jul 24, 2007 22:48

Ok, I found something on your site about the comment tab and plain text.
This works and has nothing to do with the error.

The error is still there but the program like to work fine.
Also when I press OK in the prefences screen I get the same error.

divinglog
Site Admin
Posts: 4900
Joined: Sat Feb 08, 2003 21:02
Location: Coburg
Contact:

Post by divinglog » Wed Jul 25, 2007 13:54

I think it has to do with a registry value or with a logbook value. Can you send me your PPC logbook file (*.sdf) so I can make sure that it isn't the logbook.

vasco_nl
Posts: 37
Joined: Tue Jul 24, 2007 22:25

Post by vasco_nl » Wed Jul 25, 2007 17:48

See your e-mail for my sdf-file from my PPC.

divinglog
Site Admin
Posts: 4900
Joined: Sat Feb 08, 2003 21:02
Location: Coburg
Contact:

Post by divinglog » Wed Jul 25, 2007 21:49

OK, I found the problem. In dive number 11 is no dive date entered, but this is one of the required fields in Diving Log. I'm not sure how this happened, maybe you edited the file in Access, but you can solve this problem if you enter any valid dive date in the desktop version, save the dive and sync the logbook again to the PPC.

Kind regards,
Sven

vasco_nl
Posts: 37
Joined: Tue Jul 24, 2007 22:25

Post by vasco_nl » Wed Jul 25, 2007 22:01

I started the desktop version and go to dive # 11.
There is a date, 12-11-1006, and I didn't do something with Access.
I only uses the main application entering dives.

I understand that 1006 is not right and it need to be 2006 offcourse.
I changed it and now it works fine.

Thanks for the help.

divinglog
Site Admin
Posts: 4900
Joined: Sat Feb 08, 2003 21:02
Location: Coburg
Contact:

Post by divinglog » Wed Jul 25, 2007 22:04

Thats confusing, I looked at your logbook file that you sent me and there is no date in this field. I looked in the desktop version and in Access directly. But I synced it back from the PPC format, so maybe the invalid date was lost there. Anyway, I'm happy that it works now :)

Best regards,
Sven

Post Reply