Problem with Google maps location

Discussions about Diving Log 6.0 - questions and hints
Post Reply
subgr
Posts: 2
Joined: Mon Feb 04, 2008 17:27

Problem with Google maps location

Post by subgr » Wed Jun 18, 2008 14:17

Hi there,
I am using version 4.0.10 and I found a problem with the link created for google maps.
for the following location:
Lancer II
50°44'11.1"N
0°1'0"E

The string generated for google is:
50.7364166666667,1.66666666666667E-02+(Lancer II)

1.66666666666667E-02 is a correct mathematical representation of 0.0166666666666667 but google doesn't get it.
If you use 0.0166666666666667 it's fine.
It's not a big problem but it will be nice to be fixed.

Thanks,
subgr

divinglog
Site Admin
Posts: 5085
Joined: Sat Feb 08, 2003 21:02
Location: Coburg
Contact:

Post by divinglog » Wed Jun 18, 2008 15:24

Hi subgr

Thank you for reporting this bug, I fixed it and will probably release an update next week.

Sven

froop
Posts: 13
Joined: Sun Mar 29, 2009 10:01

Re: Problem with Google maps location

Post by froop » Sun Mar 29, 2009 12:13

Has this been fixed? I've seen a similar problem;

With this site:
-38°17'58.08"N
144°33'49.74"E

Clicking the Google Maps link ends up at this location:
-37° 42' 1.92", +144° 33' 49.74"
Url used is q=-37.7005333333333,144.563816666667

I've also noticed that if I change to 38°17'58.08"S the Google Maps link disappears

divinglog
Site Admin
Posts: 5085
Joined: Sat Feb 08, 2003 21:02
Location: Coburg
Contact:

Re: Problem with Google maps location

Post by divinglog » Sun Mar 29, 2009 13:41

Hi

With 38°17'58.08"S it works for me and the Google Maps open the right location . Can you try it again with this coordinate, maybe you had a typo? Make sure you save the location first and try also to switch to another site and then back to this site before clicking the Google link. The negative value with "N" doesn't work here, too.

Kind regards,
Sven

Post Reply