Error on closing

Locked
ace1701
Posts: 6
Joined: Fri Jun 26, 2009 13:50

Error on closing

Post by ace1701 » Thu Nov 19, 2009 08:46

I have got this error when closing the program, it is since I have added a signature field to the main logbook window, there are no signatures stored yet though. Happens every time I close the program, box pops up 3 times.


See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.ArgumentException: Cannot delete a subkey tree because the subkey does not exist.
at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
at Microsoft.Win32.RegistryKey.DeleteSubKeyTree(String subkey)
at Divinglog.frmLogbook.frmLogbook_FormClosing(Object sender, FormClosingEventArgs e)
at System.Windows.Forms.Form.OnFormClosing(FormClosingEventArgs e)
at System.Windows.Forms.Form.WmClose(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

divinglog
Site Admin
Posts: 5015
Joined: Sat Feb 08, 2003 21:02
Location: Coburg
Contact:

Re: Error on closing

Post by divinglog » Fri Nov 20, 2009 13:25

Hi

Thank you for reporting this! I have fixed the bug and release later today or tomorrow an update where this fix is included. It has nothing to do with the signature panel, it was caused by the Quick Access Toolbar of the Ribbon. Do you have any tools in there or is there something else unusual?

Kind regards,
Sven

PS: I've shortened a bit the error log in your posting

ace1701
Posts: 6
Joined: Fri Jun 26, 2009 13:50

Re: Error on closing

Post by ace1701 » Sat Nov 21, 2009 19:02

No. it is exactly as it was when I started the program.

divinglog
Site Admin
Posts: 5015
Joined: Sat Feb 08, 2003 21:02
Location: Coburg
Contact:

Re: Error on closing

Post by divinglog » Sat Nov 21, 2009 20:50

The update is now online and this bug should be fixed.

Locked