WiFi sync can't be enabled

Discussions about the smartphone versions
Post Reply
Björn Van Brussel
Posts: 3
Joined: Thu Oct 12, 2017 12:36

WiFi sync can't be enabled

Post by Björn Van Brussel » Thu Oct 12, 2017 12:50

Hi all,

I started using DivingLog on my iPhone and DivingLog 6.0 on my PC a few days ago and WiFi sync was working fine. Now, today I upgraded to v2.3.1 and it seem like I can't enable WiFi sync anymore in the app. It just won't enable and stays blocked...

Are you aware of this?

canvas.png
canvas.png (41.62 KiB) Viewed 91 times
Regards
Björn

gregm
Posts: 42
Joined: Tue Jan 06, 2009 23:04
Location: Bellingham, WA, USA
Contact:

Re: WiFi sync can't be enabled

Post by gregm » Thu Oct 12, 2017 16:48

Hi Björn,

I'm a little bit confused by your message which says that Wi-Fi Sync can't be enabled and yet the screenshot that you sent shows that Wi-Fi Sync is enabled. When you see the button on the top right read "Disable Sync" that means that Dive Log has Sync enabled and is waiting for someone to connect to it. The only time that Dive Log will not be able to "Enable" sync is when you are not connected to a Wi-Fi network. Otherwise, when you tap "Enable Sync" the screen switches to the screen that you have shown and waits for a client (like Diving Log 6.0) to connect.

So, if you are indeed in the situation that you have shown in the screenshots, then the issue is likely related to your network configuration and the inability of Diving Log 6.0 to get the information that the iPhone is available for sync. The way that the sync process works is that when you tap "Enable Sync", Dive Log first publishes the availability of the "sync service" and the IP Address and Port number that the sync service can be reach at (this is done via protocol call Bonjour otherwise known as mDNS). This information is sent to your router and your router broadcasts this information to the network so that other devices (like you PC) can learn about the availability of the sync service. At this point, if you have the Sync dialog up on your PC, Diving Log 6.0 should notice the availability of the service and put your iPhone's name in the dialog box and enable the sync buttons (the PC and the iPhone have still not talked directly at this point, they are both just talking to the router). Then when you tap one of the button in the Diving Log 6.0 dialog box the PC attempts to make an actual connection to the iPhone and start the sync process (using the IP address and Port number that it learned from the router via the Bonjour protocol). Based on your screenshot, it looks like the iPhone/Dive Log have sent out the Bonjour notification. So I suspect that the PC never saw this information (since you've had this working before you obviously know what to expect on etc PC side).

I think the Dive Log update is a red herring in this case (there were no changes made to the sync code). There are a couple reasons that the PC might not see the Bonjour notifications from the router. In most cases these can easily be fixed by restarting your router (just unplug it from the wall for about 30 seconds and then plug it back in). This rests a number of internal states in the router that can cause issues with local connections. If that does not help, then you should double check the following:

1) Make sure that both the iPhone and the PC are connected to the "internal" side of your router and not the "guest" side of the router. The guest network is designed to ensure that two devices in your house can not talk to each other but only to the internet. So if either device is on the guest side of your network (the SSID usually includes the work "guest") then they will not be able to communicate.

2) If you are using a coffee shop or hotel Wi-Fi network be aware that most of these networks use a feature similar to the "guest" network feature of your home router for security of connected clients. There are ways that you can sync in this situation, so please contact me directly if this is your situation (email to "support" 'at' "moremobilesoftware" 'dot' "com").

3) Make sure that there are no firewalls that might be blocking the Bonjour protocol or Dive Log/Diving Log 6.0. You can usually solve this on your PC by adding Diving Log 6.0 to the white list of the security software. However, you might want to start by temporarily disabling your security software to see if things start working.

4) If you have a complex network, make sure that both the PC and the iPhone are on the same sub network (usually this means that their IP addresses start with the same 3 octets ... for example 10.1.0.XXX or 192.168.1.XXX, but it can be a little more complicated than that depending on your network configuration ... again, contact me directly if you need additional help with this point).

5) Make sure that you iPhone hasn't inadvertently grabbed an different network than you expected. It is not uncommon for two routers to have the same SSID and that a network your iPhone connected to elsewhere to cause it to connect to a local network with the same SSID.

Finally, if none of that helps, please send me email ("support" 'at' "moremobilesoftware" 'dot' "com") with some additional diagnostics information. You can "Enable Sync" on your iPhone and then tap the little "i" button in the lower right hand corner to view the diagnostics. Please send me the contents of that screen. Also, in Diving Log 6.0, tap the "Info" button (it might be called "Configure") in the Sync Dialog and send me the diagnostics information in that screen as well.

If in fact the issue is that you are not seeing the "Enable Sync" button in Dive Log on iPhone at all, then double check that your iPhone is connected to valid Wi-Fi router as this is a precondition for presenting the "Enable Sync" button.

Hopefully the above steps will get you going, but if not, we can certainly get this sorted out with a few more diagnostics steps (best done via email).

Cheers,

Greg
More Mobile Software
www.moremobilesofteware.com

Björn Van Brussel
Posts: 3
Joined: Thu Oct 12, 2017 12:36

Re: WiFi sync can't be enabled

Post by Björn Van Brussel » Thu Oct 12, 2017 19:37

HI Greg,

Thanks for your clear explanation. It's more clear now how sync over WiFi happens.

So, I can confirm both PC and iPhone are on the same network, on the same router (192.168.1.3) yet to make it work this time, I was forced to manually enter the sync config (sync -> info -> configure) while previously this was happening automatically.

After that manually introduction of IP and port, it worked.

So for now I can move on again :-)
Thanks for your assistance. if required, i'll get back to you.

Cheers
Björn

gregm
Posts: 42
Joined: Tue Jan 06, 2009 23:04
Location: Bellingham, WA, USA
Contact:

Re: WiFi sync can't be enabled

Post by gregm » Thu Oct 12, 2017 20:17

Hi Björn,

That certainly points to an issue with the Bonjour part of connection process. In fact, Bonjour is the only reason that the two devices need to be on the same network. If they are on different networks but are reachable then manually entering the IP address and Port Number will work.

My best guess is that there is a transient problem with your network that is affecting the broadcast of the Bonjour protocol messages. Since Bonjour literally uses "broadcast packets" to send out it's announcements which is why all the devices need to be on the same subnet (broadcast packets are not "routed" like other packet types to other subnets). In your case, it is likely that either the router or the PC have gotten into a confused sate of some sort (restarting the router and rebooting your PC are likely solutions to this). The other possibilities are a new firewall settings on either the router or the PC that are blocking the Bonjour packets or that the Bonjour server on your PC has died or become uninstalled (it is installed along with iTunes). Again, restarting the PC might resolve the later issue.

Hopefully you will find that the automatic discovery works for you again the next time that you try to sync.

Cheers,

Greg

divinglog
Site Admin
Posts: 4699
Joined: Sat Feb 08, 2003 21:02
Location: Coburg
Contact:

Re: WiFi sync can't be enabled

Post by divinglog » Fri Oct 13, 2017 17:42

Hi Björn

From your error description it still looks like a firewall issue. Please try to disable your firewall temporarily and add Diving Log to the list of allowed applications in your firewall settings.

Kind regards,
Sven

Post Reply