DC_STATUS_PROTOCOL error

Discussions about Diving Log 6.0 - questions and hints
Post Reply
dboyer
Posts: 3
Joined: Mon May 20, 2013 11:19

DC_STATUS_PROTOCOL error

Post by dboyer » Mon May 20, 2013 11:39

I am a long time Diving Log user and this is the first time I've ever had an issue that required support. I'm trying to download dives from my 2 Oceanic VEO 3.0 computers and getting a DC_STATUS_PROTOCOL error.

Some background info:
I used Diving Log on a Windows 7 laptop for a long time and it worked perfectly. About 4 months ago, I upgraded the laptop to Windows 8, reinstalled Diving Log and everything worked fine. I recently decided to roll back from Windows 8 to Windows 7. Once again reinstalled Diving Log and now I'm getting this error and can't figure it out.

Here is the dump from the Error Log:
INFO: Configure: baudrate=38400, databits=8, parity=0, stopbits=1, flowcontrol=0
INFO: Timeout: value=3000
INFO: Sleep: value=100
INFO: Flush: queue=3, input=0, output=0
INFO: Write: size=2, data=8400
INFO: Read: size=1, data=84
ERROR: Unexpected answer start byte(s). [in oceanic_atom2.c:278 (oceanic_atom2_send)]
INFO: Sleep: value=100
INFO: Flush: queue=1, input=1, output=0
INFO: Write: size=2, data=8400
INFO: Read: size=1, data=84
ERROR: Unexpected answer start byte(s). [in oceanic_atom2.c:278 (oceanic_atom2_send)]
INFO: Sleep: value=100
INFO: Flush: queue=1, input=1, output=0
INFO: Write: size=2, data=8400
INFO: Read: size=1, data=84
ERROR: Unexpected answer start byte(s). [in oceanic_atom2.c:278 (oceanic_atom2_send)]

libdivecomputer version: 0.3.0

Thanks for any help you can provide.

divinglog
Site Admin
Posts: 4698
Joined: Sat Feb 08, 2003 21:02
Location: Coburg
Contact:

Re: DC_STATUS_PROTOCOL error

Post by divinglog » Mon May 20, 2013 20:31

Hi, please try the latest beta version, which contains a new libdivecomputer version:

http://www.divinglog.de/blog/?p=1398

If it still fails, please activate "Log Errors" and attach the error log here.

Sven

dboyer
Posts: 3
Joined: Mon May 20, 2013 11:19

Re: DC_STATUS_PROTOCOL error

Post by dboyer » Mon May 20, 2013 21:41

Installed the beta and I'm still getting the error. Here is the error log:

INFO: Configure: baudrate=38400, databits=8, parity=0, stopbits=1, flowcontrol=0
INFO: Timeout: value=3000
INFO: Sleep: value=100
INFO: Flush: queue=3, input=0, output=0
INFO: Write: size=2, data=8400
INFO: Read: size=1, data=84
ERROR: Unexpected answer start byte(s). [in oceanic_atom2.c:287 (oceanic_atom2_send)]
INFO: Sleep: value=100
INFO: Flush: queue=1, input=1, output=0
INFO: Write: size=2, data=8400
INFO: Read: size=1, data=84
ERROR: Unexpected answer start byte(s). [in oceanic_atom2.c:287 (oceanic_atom2_send)]
INFO: Sleep: value=100
INFO: Flush: queue=1, input=1, output=0
INFO: Write: size=2, data=8400
INFO: Read: size=1, data=84
ERROR: Unexpected answer start byte(s). [in oceanic_atom2.c:287 (oceanic_atom2_send)]


libdivecomputer version: 0.4.0

TnT
Posts: 233
Joined: Thu Nov 29, 2007 14:53
Contact:

Re: DC_STATUS_PROTOCOL error

Post by TnT » Tue May 21, 2013 07:00

It seems that the command that is send to the dive computer is simply echoed back, instead of receiving the expected response. Are you sure you are using the correct serial port? I guess there might be something else connected to the serial port you are using. Some Oceanic cables can be connected upside down (although I don't know if that is the case for the Veo), so check that as well.

Have you tried downloading with Oceanlog? If not can you try? Just to rule out any problems with the cable.
libdivecomputer developer
Support the libdivecomputer project with a donation!
http://www.libdivecomputer.org/donate.html

dboyer
Posts: 3
Joined: Mon May 20, 2013 11:19

Re: DC_STATUS_PROTOCOL error

Post by dboyer » Tue May 21, 2013 12:12

Looks like the problem was the USB driver. I re-installed the USB download driver from the Oceanic website. It added a second COM port selection to the drop down list in the universal downloader. Chose it and now Diving Log works just fine.

Many thanks for the help!

silversinker
Posts: 3
Joined: Wed May 24, 2017 06:51

Re: DC_STATUS_PROTOCOL error

Post by silversinker » Wed May 24, 2017 07:09

I now have the same problem, having been using the app for several years. All of a sudden I get the same error message when trying to download dives. As far as I am aware, nothing has changed, log file below.

INFO: Open: name=COM6
INFO: Configure: baudrate=115200, databits=8, parity=0, stopbits=0, flowcontrol=0
INFO: Timeout: value=1000
INFO: Sleep: value=300
INFO: Purge: direction=3
INFO: Write: size=6, data=550210ED0C2E
INFO: Read: size=0, data=
ERROR: Failed to receive the packet start byte. [in divesystem_idive.c:247 (divesystem_idive_receive)]


INFO: libdivecomputer-0.dll version: 0.6.0-devel

divinglog
Site Admin
Posts: 4698
Joined: Sat Feb 08, 2003 21:02
Location: Coburg
Contact:

Re: DC_STATUS_PROTOCOL error

Post by divinglog » Wed May 24, 2017 22:20

Which dive computer? I guess your issue is unrelated to this 4 year old issue, so you should create a new thread. If it's the Ratio iX3m, it's a known issue due to the recent firmware update 4.0.

Post Reply